MLPoLNS – Configuration

CPE
====

multilink bundle-name authenticated
!
interface Multilink100
ip address negotiated
ppp chap hostname mlpoa100
ppp multilink
ppp multilink interleave
ppp multilink group 100
!
interface Multilink101
ip address negotiated
ppp chap hostname mlpoa101
ppp multilink
ppp multilink interleave
ppp multilink group 101
!
interface ATM6/0/0
no ip address
!
interface ATM6/0/0.11 multipoint
range pvc 1/201 1/202
vbr-nrt 256 256
encapsulation aal5mux ppp Virtual-Template10
!
!
interface ATM6/0/0.100 point-to-point
pvc 1/100
ppp chap hostname mlpoa100
ppp multilink group 100
vbr-nrt 25600 25600
encapsulation aal5mux ppp Virtual-Template100
!
!
interface ATM6/0/0.101 point-to-point
pvc 1/101
ppp chap hostname mlpoa101
ppp multilink group 101
vbr-nrt 25600 25600
encapsulation aal5mux ppp Virtual-Template101
!
!
interface Virtual-Template10
ip address negotiated
no peer default ip address
no keepalive
ppp pap sent-username pink@brown password 0 red
!
interface Virtual-Template100
ip address negotiated
no peer default ip address
no keepalive
ppp pap sent-username blue@black password 0 green
ppp multilink
!
interface Virtual-Template101
ip address negotiated
no peer default ip address
no keepalive
ppp pap sent-username user101@brown password 0 red
ppp multilink
!

LAC
====
multilink bundle-name authenticated
vpdn enable
!
vpdn-group tunnel10
request-dialin
protocol l2tp
domain brown
initiate-to ip 70.1.1.2
local name plain_ppp_lac
l2tp tunnel password 0 cisco
l2tp tunnel receive-window 2048
!
vpdn-group tunnel100
request-dialin
protocol l2tp
domain black
initiate-to ip 70.1.1.2
local name mlpoaog_LAC_atm
l2tp tunnel password 0 cisco
l2tp tunnel receive-window 2048
!
interface GigabitEthernet8/0/0.1
encapsulation dot1Q 3
ip address 70.1.1.1 255.0.0.0
!
interface ATM6/0/0
no ip address
atm clock INTERNAL
atm over-subscription-factor 200
!
interface ATM6/0/0.10 point-to-point
pvc 1/10
vbr-nrt 256 256
encapsulation aal5mux ppp Virtual-Template10
!
!
interface ATM6/0/0.11 multipoint
range pvc 1/201 1/202
vbr-nrt 256 256
encapsulation aal5mux ppp Virtual-Template10
!
!
interface ATM6/0/0.100 point-to-point
pvc 1/100
ppp chap hostname mlpoa100
vbr-nrt 140000 140000
encapsulation aal5mux ppp Virtual-Template100
!
!
interface ATM6/0/0.101 point-to-point
pvc 1/101
ppp chap hostname mlpoa101
vbr-nrt 140000 140000
encapsulation aal5mux ppp Virtual-Template101
!
!
interface Virtual-Template10
no ip address
no peer default ip address
no keepalive
ppp authentication pap
!
interface Virtual-Template100
no ip address
no peer default ip address
no keepalive
ppp authentication pap
ppp multilink
!
interface Virtual-Template101
no ip address
no peer default ip address
no keepalive
ppp authentication pap
ppp multilink
!

LNS
===
multilink bundle-name authenticated
vpdn enable
!
vpdn-group tunnel10
accept-dialin
protocol l2tp
virtual-template 10
terminate-from hostname plain_ppp_lac
local name plain_ppp_lns
lcp renegotiation always
l2tp tunnel password 0 cisco
l2tp tunnel retransmit retries 7
l2tp tunnel retransmit timeout min 2
ip tos reflect
!
vpdn-group tunnel100
accept-dialin
protocol l2tp
virtual-template 10
terminate-from hostname mlpoaog_LAC_atm
local name mlpoaog_LNS_1
lcp renegotiation always
l2tp tunnel password 0 cisco
l2tp tunnel retransmit retries 7
l2tp tunnel retransmit timeout min 2
!
vpdn-group tunnel101
accept-dialin
protocol l2tp
virtual-template 10
terminate-from hostname mlpoaog_LAC_atm_101
local name mlpoaog_LNS_1_101
lcp renegotiation always
l2tp tunnel password 0 cisco101
l2tp tunnel retransmit retries 7
l2tp tunnel retransmit timeout min 2
!
username pink@brown password 0 red
username blue@black password 0 green
username user101@brown password 0 red
!
interface Loopback10
ip address 200.1.1.1 255.255.255.255
!
interface GigabitEthernet 1/0/0.1
encapsulation dot1Q 3
ip address 70.1.1.2 255.0.0.0
!
interface Virtual-Template10
ip unnumbered Loopback10
peer default ip address pool pool-10
no keepalive
ppp authentication pap callin
ppp multilink
ppp multilink links maximum 1
ppp multilink endpoint magic-number
!
ip local pool pool-10 200.1.1.2 200.1.100.100 group dial

To establish sessions

On CPE

test pppoe  100 5  ATM6/0/0.100

[This command will bring-up 100 session with a call rate or 5 calls/sec through atm 6/0/0.100 ]

 

To verify sessions established

On LNS

#sh caller summary

#sh subsc sess

#sh users

www.pdf24.org    Send article as PDF   

Leave a Reply

Your email address will not be published. Required fields are marked *


*